Technical requirements

Polyglobe employs the most up-to-date web techniques and operates best in the latest web browsers. The following table shows which browser software best supports Polyglobe.
Browser Supports Polyglobe? Speed Remarks
Internet Explorer v6 no ./. ./.
Internet Explorer v7 yes slow no chart view
Internet Explorer v8 yes sufficient ./.
Internet Explorer v9+ yes fast ./.
Firefox v3.6+ yes fast ./.
Google Chrome v10+ yes very fast ./.
Apple Safari (v5+) yes very fast ./.
Opera v10+ yes very fast ./.